
1/3/2019 Create and verify PDF accessibility, Acrobat Pro

https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html 1/35

ON THIS PAGE

Make PDFs accessible

(Acrobat Pro)

Check accessibility of PDFs

(Acrobat Pro)

Fix accessibility issues

(Acrobat Pro)

Accessibility issues

WCAG mapping to PDF/UA

Applies to: Acrobat 2017,  Acrobat

DC

Last Published: February 13, 2018

Acrobat tools make it easy to create accessible PDFs and check the

accessibility of existing PDFs. You can create PDFs to meet common

accessibility standards, such as Web Content Accessibility Guidelines

(WCAG) 2.0 and PDF/UA (Universal Access, or ISO 14289). The simple,

guided workflow lets you do the following:

Make PDFs accessible: A predefined action automates many tasks,

checks accessibility, and provides instructions for items that require

manual fixes. Quickly find and fix problem areas.

Check accessibility: The Full Check tool verifies whether the

document conforms to accessibility standards, such as PDF/UA and

WCAG 2.0.

Report accessibility status: The Accessibility Report summarizes the

findings of the accessibility check. It contains links to tools and

documentation that assist in fixing problems.

Make PDFs accessible (Acrobat Pro)

The Make Accessible action walks you through the steps required to

make a PDF accessible. It prompts to address accessibility issues, such

as a missing document description or title. It looks for common

elements that need further action, such as scanned text, form fields,

tables, and images. You can run this action on all PDFs except

dynamic forms (XFA documents) or portfolios.

Create and verify PDF accessibility (Acrobat Pro)

Search Adobe Support 

Accessibility, tags, and reflow

Choose Tools > Action Wizard.

The Action Wizard toolset is displayed in the secondary toolbar.

1
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Note:

A list of available actions is displayed under the Action List in the

right-hand pane.

From the Action List, click Make Accessible.

The right-hand pane changes to display each task included in

the Make Accessible action, as well as the instructions to

execute the action.

2

Select the files that you want to apply the Make Accessible

action to. By default, the action runs on the document that's

currently open. Select Add Files to select additional files or a

folder to run the action on.

Select Add Files to run the report on additional files or folders.

3

Click Start.4

Follow the prompts to complete the Make Accessible action.5
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Check accessibility of PDFs (Acrobat Pro)

A good way to check the accessibility of a document is to use tools

that your readers will use. Even if you do not have access to those

tools, Adobe Acrobat provides an automated way to check the

accessibility of a PDF file. The Full Check feature in Acrobat checks a

PDF for many of the characteristics of accessible PDFs. You can

choose which accessibility problems to look for and how you want

the results reported.

Choose Tools > Accessibility.

The Accessibility toolset is displayed in the secondary toolbar.

1

In the secondary toolbar, click Full Check.

The Accessibility Checker Options dialog box is displayed.

2

In the Report Options section, select options for how you want

to view the results. You can save the results as an HTML file on

your system, or attach the results file to the document itself.

3

Select a page range if you prefer to check individual pages of a

document.

Note:

When you have a large document, running a full check one page

at a time can be more efficient.

4

Select one or more of the Checking Options.5

Click Start Checking. The results are displayed in the

Accessibility Checker panel on the left, which also has helpful

links and hints for repairing issues. If you created a report in step

2, the results are available in the selected folder.

Because the Full Check feature cannot distinguish between

essential and nonessential content types, some issues it reports

don’t affect readability. It’s a good idea to review all issues to

determine which ones require correction.

6
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Note:

In addition to Full Check, Acrobat provides other methods to check PDF

accessibility:

Use Reflow view to quickly check the reading order.

Use Read Out Loud to experience the document as readers who

use the text-to-speech conversion tool experience it.

Save the document as accessible text and then read the saved text

file in a word-processing application. This exercise enables you to

The report displays one of the following statuses for each rule

check:

Passed: The item is accessible.

Skipped By User: Rule was not checked because it wasn't

selected in the Accessibility Checker Options dialog box.

Needs Manual Check: The Full Check feature couldn't check

the item automatically. Verify the item manually.

Failed: The item didn't pass the accessibility check.

Accessibility Checker rules statuses.

https://helpx.adobe.com/acrobat/using/reading-pdfs-reflow-accessibility-features.html#reflow_a_pdf
https://helpx.adobe.com/acrobat/using/reading-pdfs-reflow-accessibility-features.html#read_a_pdf_with_read_out_loud
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Fix:

Skip Rule:

Explain:

Check Again:

Show Report:

Options:

emulate the end-user experience of readers who use a braille

printer to read the document.

Use the Reading Order tool, Order, Tags, and Content panels to

examine the structure, reading order, and contents of a PDF.

Fix accessibility issues (Acrobat Pro)

To fix a failed check after running Full Check, right-click (Windows) or

Ctrl-click (Mac OS) the item in the Accessibility Checker panel.

Choose one of the following options from the context menu:

Acrobat either fixes the item automatically, or displays a dialog

box prompting you to fix the item manually.

Deselects this option in the Accessibility Checker

Options dialog box for future checks of this document, and changes

the item status to Skipped.

Opens the online Help  where you can get more details

about the accessibility issue.

Runs the checker again on all items. Choose this

option after modifying one or more items.

Displays a report with links to tips on how to repair

failed checks.

Opens the Accessibility Checker Options dialog box, so

you can select which checks are performed.

Accessibility issues

Document

Prevent security settings from interfering with screen
readers

https://helpx.adobe.com/acrobat/using/touch-reading-order-tool-pdfs.html
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A document author can specify that no part of an accessible PDF is to

be copied, printed, extracted, commented on, or edited. This setting

could interfere with a screen reader's ability to read the document,

because screen readers must be able to copy or extract the

document's text to convert it to speech.

This flag reports whether it's necessary to turn on the security settings

that allow accessibility.

To fix the rule automatically, select Accessibility Permission Flag on

the Accessibility Checker panel. Then, choose Fix from the Options 

 menu.

Or, fix accessibility permissions manually:

If your assistive technology product is registered with Adobe as a

Trusted Agent, you can read PDFs that might be inaccessible to

another assistive technology product. Acrobat recognizes when a

screen reader or other product is a Trusted Agent and overrides

security settings that would typically limit access to the content for

accessibility purposes. However, the security settings remain in effect

for all other purposes, such as to prevent printing, copying, extracting,

commenting, or editing text.

Note:

See the related WCAG section: 1.1.1 Non-text Content. (A), 4.1.2 Name,

role, value

Image-only PDF

Reports whether the document contains non-text content that is not

accessible. If the document appears to contain text, but doesn't

contain fonts, it could be an image-only PDF file.

To fix this rule check automatically, select Image-only PDF on the

Accessibility Checker panel, and choose Fix from the Options 

Choose File > Properties > Security.1

Choose No Security from the Security Method drop-down list.2

Click OK and close the Document Properties dialog box.3
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menu.

Or, to fix this rule check manually, use OCR to recognize text in

scanned images:

Note:

See the related WCAG section: 1.1.1. Non-text content (A)

Tagged PDF

If this rule check fails, the document isn't tagged to specify the correct

reading order.

To fix this item automatically, select Tagged PDF on the Accessibility

Checker panel, and then choose Fix from the Options  menu.

Acrobat automatically adds tags to the PDF.

To specify tags manually, do one of the following:

Enable tagging in the application in which the PDF was authored,

and re-create the PDF.

Choose Tools > Accessibility > Autotag Document in Acrobat.

The Add Tags Report appears in the navigation pane if there are

any issues. The report lists potential problems by page, provides a

navigational link to each problem, and provides suggestions for

fixing them.

Choose Tools > Accessibility > Reading Order in Acrobat, and

create the tags tree. For more information, see Reading Order

tool overview.

Open the Tags  panel and create the tags tree manually. To

display the Tags panel, choose View > Show/Hide > Navigation

Choose Tools > Enhance Scans.

The Enhance Scans toolset is displayed in the secondary toolbar.

1

In the secondary toolbar, choose Recognize Text > In This File.2

Select the pages you want to process, the document language,

and then click  Recognize Text.

3

https://helpx.adobe.com/acrobat/using/touch-reading-order-tool-pdfs.html
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Panes > Tags. For more information, see Edit document structure

with the Content and Tags panel.

Note:

See the related WCAG section: 1.3.1 Info and Relationships, 1.3.2, 2.4.1,

2.4.4, 2.4.5, 2.4.6, 3.1.2, 3.3.2, 4.1.2 Name, role, value

Logical reading order

Verify this rule check manually. Make sure that the reading order

displayed in the Tags panel coincides with the logical reading order of

the document.

Document language

Setting the document language in a PDF enables some screen readers

to switch to the appropriate language. This check determines whether

the primary text language for the PDF is specified. If the check fails, set

the language.

To set the language automatically, select Primary Language in the

Accessibility Checker tab, and then choose Fix from the Options 

menu. Choose a language in the Set Reading Language dialog box,

and then click OK.

To set the language manually, do one of the following:

Choose File > Properties > Advanced and then select a language

from the drop-down list in the Reading Options section. (If the

language doesn't appear in the drop-down list, you can enter the

ISO 639 code for the language in the Language field.) This setting

applies the primary language for the entire PDF.

Set the language for all text in a subtree of the tags tree. Open the

Tags  panel. Expand the Tags root and select an element. Then

choose Properties from the Options  menu. Choose a

language from the Language drop-down list. (To display the Tags

panel, choose View > Show/Hide > Navigation Panes > Tags.)

Set the language for a block of text by selecting the text element

or container element in the Content  panel. Then, right-click

(Windows) or Ctrl-click (Mac OS) the text and choose Properties

from the context menu and choose a language from the

https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html
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Language drop-down list. (To display the Content panel, choose

View > Show/Hide > Navigation Panes > Content.)

Note:

See the related WCAG section: Language of Page (Level A)

Title

Reports whether there is a title in the Acrobat application title bar.

To fix the title automatically, select Title in the Accessibility Checker

tab, and choose Fix from the Options  menu. Enter the document

title in the Description dialog box (deselect Leave As Is, if necessary).

Or, fix the title manually:

Note:

See the related WCAG section: 2.4 Page Titled (Level A)

Bookmarks

This check fails when the document has 21 or more pages, but doesn't

have bookmarks that parallel the document structure.

To add bookmarks to the document, select Bookmarks on the

Accessibility Checker panel, and choose Fix from the Options 

menu. In the Structure Elements dialog box, select the elements that

you want to use as bookmarks, and click OK. (You can also access the

Structure Elements dialog box by clicking the Options menu on the

Choose File > Properties > Description.1

Enter a title in the Title text box.2

Click Initial View, and then choose Document Title from the

Show drop-down list. 

3

Click OK to close the Description dialog box.4
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Bookmark tab and selecting the New Bookmarks From Structure

command.)

Note:

See the related WCAG sections: 2.4.1 Bypass Blocks (Level A), 2.4.5

Multiple Ways (Level AA)

Color contrast

When this check fails, it's possible that the document contains content

that isn't accessible to people who are color-blind.

To fix this issue, make sure that the document's content adheres to the

guidelines outlined in WCAG section 1.4.3. Or, include a

recommendation that the PDF viewer use high-contrast colors:

Page content

Tagged content

This check reports whether all content in the document is tagged.

Make sure that all content in the document is either included in the

Tags tree, or marked as an artifact.

Do one of the following to fix this rule check:

Open the Content  panel and right-click (Windows) or Ctrl-

click (Mac OS) the content that you want to mark as an artifact.

Then, select Create Artifact from the context menu. (To display

the Content tab, choose View > Show/Hide > Navigation Panes

> Content.)

Choose Edit > Preferences (Windows) or Acrobat >

Preferences (Mac OS).

1

Click Accessibility.2

Select Replace Document Colors, and then select Use High-

Contrast Colors. Choose the color combination that you want

from the drop-down list, and then click OK.

3
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Tag the content by choosing Tools > Accessibility > Reading

Order. Select the content, and then apply tags as necessary.

Assign tags using the Tags  panel. Right-click (Windows) or

Ctrl-click (Mac OS) the element in the Tags tree, and choose

Create Tag From Selection. Items such as comments, links, and

annotations don't always appear in the Tags tree. To find these

items, choose Find from the Options menu. (To display the Tags

panel, choose View > Show/Hide > Navigation Panes > Tags.)

Note:

See the related WCAG sections: 1.1.1 Non-text content (A), 1.3.1 Info and

Relationships (Level A), 1.3.2 Meaningful Sequence (Level A), 2.4.4 Link

Purpose (In Context) (Level A), 3.1.2 Language of Parts (Level AA), 4.1.2

Name, role, value

Tagged annotations

This rule checks whether all annotations are tagged. Make sure that

annotations such as comments and editorial marks (such as insert

and highlight) are either included in the Tags tree or marked as

artifacts.

Open the Content  panel, and right-click (Windows) or Ctrl-

click (Mac OS) the content that you want to mark as an artifact.

Then, select Create Artifact from the context menu. (To display

the Content panel, choose View > Show/Hide > Navigation

Panes > Content.)

Tag the content by choosing Tools > Accessibility > Reading

Order. Select the content, and then apply tags as necessary.

Assign tags using the Tags  panel. (To display the Tags panel,

choose View > Show/Hide > Navigation Panes > Tags.)

To have Acrobat assign tags automatically to annotations as they're

created, choose Tag Annotations from the Options menu on the Tags

panel.

Note:

See the related WCAG section: 1.3.1 Info and Relationships (Level A), 4.1.2

Name, role, value
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Tab order

Because tabs are often used to navigate a PDF, it's necessary that the

tab order parallels the document structure.

To fix the tab order automatically, select Tab Order on the

Accessibility Checker panel, and choose Fix from the Options 

menu.

To manually fix the tab order for links, form fields, comments, and

other annotations:

Note:

See the related WCAG section: 2.4.3, Focus Order (Level A)

Character encoding

Specifying the encoding helps PDF viewers' present users with

readable text. However, some character-encoding issues aren't

repairable within Acrobat.

To ensure proper encoding, do the following:

Verify that the necessary fonts are installed on your system.

Use a different font (preferably OpenType) in the original

document, and then re-create the PDF.

Re-create the PDF file with a newer version of Acrobat Distiller.

Use the latest Adobe Postscript driver to create the PostScript file,

and then re-create the PDF.

Click the Page Thumbnails panel on the navigation pane.1

Click a page thumbnail, and then choose Page Properties from

the Options  menu.

2

In the Page Properties dialog box, choose Tab Order. Then,

select Use Document Structure, and click OK.

3

Repeat these steps for all thumbnails in the document.4
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Note:

The WCAG doesn't address Unicode character mapping.

Tagged multimedia

This rule checks whether all multimedia objects are tagged. Make

sure that content is either included in the Tags tree or marked as an

artifact.

Open the Content  panel and right-click (Windows) or Ctrl-click

(Mac OS) the content that you want to mark as an artifact. Then,

select Create Artifact from the context menu. (To display the Content

panel, choose View > Show/Hide > Navigation Panes > Content.)

Tag the content by choosing Tools > Accessibility > Reading Order.

Select the content, and then apply tags as necessary.

Assign tags using the Tags  panel. Right-click (Windows) or Ctrl-

click (Mac OS) the element in the Tags tree, and choose Create Tag

From Selection. (To display the Tags panel, choose View >

Show/Hide > Navigation Panes > Tags.)

Note:

See the related WCAG sections: 1.1.1 Non-text Content. (A), 1.2.1 Audio-

only and Video- only (Prerecorded). (A), 1.2.2 Captions (Prerecorded).

(A), 1.2.3 Audio Description or Media Alternative (Prerecorded). (A), 1.2.5

Audio Description (Prerecorded). (AA)

Screen flicker

Elements that make the screen flicker, such as animations and scripts,

can cause seizures in individuals who have photosensitive epilepsy.

These elements can also be difficult to see when the screen is

magnified.

If the Screen Flicker rule fails, manually remove or modify the script

or content that causes screen flicker.

Note:
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See these related WCAG sections: 1.1.1 Non-text Content. (A), 1.2.1 Audio-

only and Video- only (Prerecorded). (A), 1.2.2 Captions (Prerecorded).

(A), 1.2.3 Audio Description or Media Alternative (Prerecorded). (A), 2.3.1

Three Flashes or Below Threshold. (Level A)

Scripts

Content cannot be script-dependent unless both content and

functionality are accessible to assistive technologies. Make sure that

scripting doesn't interfere with keyboard navigation or prevent the

use of any input device.

Check the scripts manually. Remove or modify any script or content

that compromises accessibility.

Note:

See these related WCAG sections: 1.1.1 Non-text Content. (A), 2.2.2 Pause,

Stop, Hide. (Level A), 4.1.2 Name, role, value

Timed responses

This rule check applies to documents that contain forms with

JavaScript. If the rule check fails, make sure that the page does not

require timed responses. Edit or remove scripts that impose timely

user response so that users have enough time to read and use the

content.

Note:

See the related WCAG section: 2.2.1 Timing Adjustable. (Level A)

Accessible links

For URLs to be accessible to screen readers, they must be active links

that are correctly tagged in the PDF. (The best way to create

accessible links is with the Create Link command, which adds all

three links that screen readers require to recognize a link.) Make sure

that navigation links are not repetitive and that there is a way for

users to skip over repetitive links.
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If this rule check fails, check navigation links manually and verify that

the content does not have too many identical links. Also, provide a

way for users to skip over items that appear multiple times. For

example, if the same links appear on each page of the document, also

include a "Skip navigation" link.

Note:

See the related WCAG section: 2.4.1 Bypass Blocks. (Level A)

Forms

Tagged form fields

In an accessible PDF, all form fields are tagged and are a part of the

document structure. In addition, you can use the tool tip form filed

property to provide the user with information or to provide

instructions.

To tag form fields, choose Tools > Accessibility > Autotag Form

Fields.

Note:

See the related WCAG sections: 1.3.1 Info and Relationships. (Level A),

4.1.2 Name, role, value

Field descriptions

For accessibility, all form fields need a text description (tool tip).

To add a text description to a form field:

1. Select one of the Form tools, and then right-click (Windows) or

Ctrl-click (Mac OS) the form field.

2. Choose Properties from the context menu.

3. Click the General properties tab.

4. Enter a description of the form field in the Tooltip field.

Note:
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See the related WCAG sections: 1.3.1 Info and Relationships. (Level A),

3.3.2 Labels or Instructions (Level A), 4.1.2 Name, role, value

Alternate text

Figures alternate text

Make sure that images in the document either have alternate text or

are marked as artifacts.

If this rule check fails, do one of the following:

Select Figures Alternate Text in the Accessibility Checker panel,

and choose Fix from the Options  menu. Add alternate text as

prompted in the Set Alternate Text dialog box.

Use the Tags panel to add alternate text for images in the PDF.

Open the Content  panel and right-click (Windows) or Ctrl-

click (Mac OS) the content that you want to mark as an artifact.

Then, select Create Artifact from the context menu. (To display

the Content panel, choose View > Show/Hide > Navigation

Panes > Content.)

Note:

See the related WCAG section: 1.1.1 Non-text Content. (A)

Nested alternate text

Screen readers don't read the alternate text for nested elements.

Therefore, don't apply alternate text to nested elements.

To remove alternate text from nested elements, do the following:

1. Choose View > Show/Hide > Navigation Panes > Tags.

2. Right-click (Windows) or Ctrl-click (Mac OS) a nested element in

the Tags panel and choose Properties from the context menu.

3. Remove both the Alternate Text and the text to which it's applied

from the Object Properties dialog box, and then click Close.

Note:

https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html#add_alternate_text_and_supplementary_information_to_tags
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See the related WCAG section: #1.1.1 Non-text Content. (A)

Associated with content

Make sure that alternate text is always an alternate representation for

content on the page. If an element has alternate text, but does not

contain any page content, there is no way to determine which page it

is on. If the Screen Reader Option in the Reading preferences is not

set to read the entire document, then screen readers never read the

alternate text.

1. Right-click (Windows) or Ctrl-click (Mac OS) an item to check.

2. Open it in the Tags  panel. (To display the Tags panel, choose

View > Show/Hide > Navigation Panes > Tags.)

3. Remove the Alternate Text from the Tags panel for any nested

item that has no page content.

Note:

See the related WCAG section: 1.1.1 Non-text Content. (A)

Hides annotation

Alternate text can't hide an annotation. If an annotation is nested

under a parent element with alternate text, then screen readers don't

see it.

To remove alternate text from nested elements:

1. Choose View > Show/Hide > Navigation Panes > Tags.

2. Right-click (Windows) or Ctrl-click (Mac OS) a nested element in

the Tags panel and choose Properties from the context menu.

3. Remove the alternate text from the Object Properties dialog box,

and then click OK.

Note:

See the related WCAG sections: 1.3.1 Info and Relationships. (Level A),

4.1.2 Name, role, value
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Other elements alternate text

This report checks for content, other than figures, that requires

alternate text (such as multimedia, annotation, or 3D model). Make

sure that alternate text is always an alternate representation for

content on the page. If an element has alternate text but does not

contain any page content, there is no way to determine which page it

is on. If the Screen Reader Options in the Reading preferences is not

set to read the entire document, then screen readers don't read the

alternate text.

1. Choose View > Show/Hide > Navigation Panes > Tags.

2. Right-click (Windows) or Ctrl-click (Mac OS) a nested element in

the Tags  panel and choose Properties from the context

menu.

3. Remove the alternate text from the Object Properties dialog box,

and then click OK.

Note:

See the related WCAG section: 1.1.1 Non-text Content. (A)

Tables

Because table structure can be complex, it is best practice to check

them for accessibility manually.

Rows

This rule checks whether each TR in a table is a child of Table, THead,

TBody, or TFoot.

See Correct table tags with the Tags panel.

Note:

Related WCAG section: 1.3.1 Info and Relationships. (Level A)

TH and TD

In a proper table structure, TH and TD are children of TR.

https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html#add_alternate_text_and_supplementary_information_to_tags
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See Correct table tags with the Tags panel.

Note:

See related WCAG section: #1.3.1 Info and Relationships. (Level A)

Headers

For accessibility, it's necessary that all tables in the PDF have a header.

See Correct table tags with the Tags panel.

Note:

See the related WCAG section: 1.3.1 Info and Relationships. (Level A)

Regularity

To be accessible, tables must contain the same number of columns in

each row, and rows in each column.

See Correct table tags with the Tags panel.

Note:

See the related WCAG section: 1.3.1 Info and Relationships. (Level A)

Summary

Table summaries are optional, but can improve accessibility.

1. Choose Tools > Accessibility > Reading Order.

2. Select the table by drawing a rectangle around it. 

3. In the Reading Order dialog box, click Table.

4. Right-click (Windows) or Ctrl-click (Mac OS) Table.

5. Click Edit Table Summary.

6. Enter a summary and click OK.

Note:

https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html#add_alternate_text_and_supplementary_information_to_tags
https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html#add_alternate_text_and_supplementary_information_to_tags
http://help.adobe.com/en_US/acrobat/using/WS58a04a822e3e50102bd615109794195ff-7cdb.w.html
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See the related WCAG section: 1.3.1 Info and Relationships. (Level A)

Lists

List items

The check reports whether each List Item (LI) is a child of List (L).

When this rule check fails, the structure of this list is incorrect. Lists

must have the following structure: A List element must contain List

Item Elements. And, List Item Elements can only contain Label

Elements and List Item Body Elements.

To fix the list structure:

1. Find the list in the Accessibility Checker panel by right-clicking

(Windows) or Ctrl-clicking (Mac OS) the failed element and

choosing Show In Tags Panel.

2. Create elements, change the types of elements, or rearrange

existing elements by dragging them.

Note:

See the related WCAG section: 1.3.1 Info and Relationships. (Level A)

Lbl and LBody

Lists must have the following structure: A List element must contain

List Item Elements. And, List Item Elements can only contain Label

Elements and List Item Body Elements. When this rule check fails,

the structure of this list is incorrect.

To fix the list structure:

1. Find the list in the Accessibility Checker panel by right-clicking

(Windows) or Ctrl-clicking (Mac OS) the failed element and

choosing Show In Tags Panel.

2. Create elements, change the types of elements, or rearrange

existing elements by dragging them.

Note:

See the related WCAG section: 1.3.1 Info and Relationships. (Level A)
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Headings

Appropriate nesting

This rule checks nested headings. When this check fails, headings are

not nested properly.

To fix the list structure:

1. Find the list in the Accessibility Checker panel by right-clicking

(Windows) or Ctrl-clicking (Mac OS) the failed element and

choosing Show in Tags Panel.

2. Create elements, change the types of elements, or rearrange

existing elements by dragging them.

Note:

See the related WCAG section: 2.4.6 Headings and Labels. (Level AA).

The order of headings is not required under WCAG, and is only an

advisory technique.

WCAG mapping to PDF/UA

WCAG 2.0 ISO 14289 -1 (File) Techniques

1.1.1 Non-text

Content. (A)
7.3 addresses

content

requiring text

alteration.

7.18.1

paragraph

four

addresses

control

descriptions.

7.18.6.2

addresses

time-based

PDF1

PDF4

http://www.w3.org/TR/WCAG20-TECHS/PDF1.html
http://www.w3.org/TR/WCAG20-TECHS/PDF4.html


1/3/2019 Create and verify PDF accessibility, Acrobat Pro

https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html 22/35

media

alternatives.

Test, Sensory,

and

CAPTCHA

use-cases are

addressed via

the technical

means used.

7.1 paragraph

1, sentence 2

addresses

decoration.

1.2.1 Audio-

only and

Video- only

(Prerecorded).

(A)

7.18.6.2

addresses

time-based

media

alternatives.

Design-

specific. It's

necessary

that authors

and

developers

consider this

provision and

ensure

conformance.

General Techniques:

http://www.w3.org/WAI/W

media-equiv-av-only-alt

1.2.2 Captions

(Prerecorded).

(A)

7.18.6.2

addresses

time-based

media

alternatives.

Design-

specific. It's

necessary

General Techniques:

http://www.w3.org/WAI/W

media-equiv-captions

http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-av-only-alt
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-captions
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that authors

and

developers

consider this

provision and

ensure

conformance.

1.2.3 Audio

Description or

Media

Alternative

(Prerecorded).

(A)

7.18.6.2

addresses

time-based

media

alternatives.

Design-

specific. It's

necessary

that authors

and

developers

consider this

provision and

ensure

conformance.

General Techniques:

http://www.w3.org/WAI/W

media-equiv-audio-desc

1.2.4 Captions

(Live). (AA)
Design-

specific. It's

necessary

that authors

and

developers

consider this

provision and

ensure

conformance.

General Techniques:

http://www.w3.org/WAI/W

media-equiv-real-time-ca

1.2.5 Audio

Description
7.18.6.2

addresses

time-based

General Techniques:

http://www.w3.org/WAI/W

media-equiv-audio-desc-

http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-real-time-captions
http://www.w3.org/WAI/WCAG20/quickref/#qr-media-equiv-audio-desc-only
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(Prerecorded).

(AA)

media

alternatives.

Design-

specific. It's

necessary

that authors

and

developers

consider this

provision and

ensure

conformance.

1.2.6 Sign

Language

(Prerecorded).

(AAA)

Design-

specific. It's

necessary

that authors

and

developers

consider this

provision and

ensure

conformance.

 

1.2.7 Extended

Audio

Description

(Prerecorded).

(AAA)

Design-

specific. It's

necessary

that authors

and

developers

consider this

provision and

ensure

conformance

 

1.2.8 Media

Alternative
7.18.6.2

addresses

time-based
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(Prerecorded).

(AAA)

media

alternatives.

Design-

specific. It's

necessary

that authors

and

developers

consider this

provision and

ensure

conformance.

1.2.9 Audio-

only (Live).

(AAA)

Design-

specific. It's

necessary

that authors

and

developers

consider this

provision and

ensure

conformance.

 

1.3.1 Info and

Relationships.

(Level A)

7.1 - 7.10 and

7.20 address

structure and

relationships

in content.

7.17 and 7.18

address

structure and

relationships

in

annotations.

PDF6 

PDF9 

PDF10

PDF11 

PDF12

PDF17

PDF20

PDF21

1.3.2

Meaningful
7.2 paragraph

two

PDF3

http://www.w3.org/TR/WCAG20-TECHS/PDF6.html
http://www.w3.org/TR/WCAG20-TECHS/PDF9.html
http://www.w3.org/TR/WCAG20-TECHS/PDF10.html
http://www.w3.org/TR/WCAG20-TECHS/PDF11.html
http://www.w3.org/TR/WCAG20-TECHS/PDF12.html
http://www.w3.org/TR/WCAG20-TECHS/PDF17.html
http://www.w3.org/TR/WCAG20-TECHS/PDF20.html
http://www.w3.org/TR/WCAG20-TECHS/PDF21.html
http://www.w3.org/TR/WCAG20-TECHS/PDF3.html
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Sequence.

(Level A)

addresses the

meaningful

sequence of

content.

7.17 addresses

navigation

features.

7.18.3

addresses tab

order in

annotations.

1.3.3 Sensory

Characteristics.

(Level A)

7.1,

paragraphs 6

and 7

General Techniques:

http://www.w3.org/WAI/W

content-structure-separa

1.4.1 Use of

Color. (Level

A)

7.1, paragraph

6

General Techniques:

http://www.w3.org/WAI/W

visual-audio-contrast-wit

1.4.2 Audio

Control. (Level

A)

Design-

specific. It's

necessary

that authors

and

developers

consider this

provision and

ensure

conformance.

General Techniques:

http://www.w3.org/WAI/W

visual-audio-contrast-dis

1.4.3 Contrast

(Minimum).

(Level AA)

7.1, paragraph

6 and note 4

General Techniques:

http://www.w3.org/WAI/W

visual-audio-contrast-con

1.4.4 Resize
Not G142

http://www.w3.org/WAI/WCAG20/quickref/#qr-content-structure-separation-understanding
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-without-color
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-dis-audio
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-contrast
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G142
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text. (Level

AA)

applicable

1.4.5 Images of

Text. (Level

AA)

7.3, paragraph

6

PDF7

General Techniques:

http://www.w3.org/WAI/W

visual-audio-contrast-tex

1.4.6 Contrast

(Enhanced).

(Level AAA)

7.1, paragraph

6

 

1.4.7 Low or

No

Background

Audio. (Level

AAA)

While ISO

14289 does

not address

this success

criterion,

conformance

in PDF

requires ISO

14289

conforming

files and

readers. The

manner in

which

developers

support this

success

criterion in

PDF in not

defined in

ISO 14289 or

ISO 32000.

 

1.4.8 Visual

Presentation.

(Level AAA)

Design-

specific. It's

necessary

 

http://www.w3.org/TR/WCAG20-TECHS/PDF7.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-visual-audio-contrast-text-presentation
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that authors

and

developers

consider this

provision and

ensure

conformance.

1.4.9 Images of

Text (No

Exception).

(Level AAA)

7.3 paragraph

1

 

2.1.1 Keyboard.

(Level A)
Not

applicable

PDF3 

PDF11 

PDF23

2.1.2 No

Keyboard Trap.

(Level A)

Design-

specific. It's

necessary

that

developers

consider this

provision and

ensure

conformance.

G21

2.1.3 Keyboard

(No

Exception).

(Level AAA)

7.19,

paragraph 3

 

2.2.1 Timing

Adjustable.

(Level A)

7.19,

paragraph

three applies,

but generally

this rule is

design-

G133

http://www.w3.org/TR/WCAG20-TECHS/PDF3.html
http://www.w3.org/TR/WCAG20-TECHS/PDF11.html
http://www.w3.org/TR/WCAG20-TECHS/PDF23.html
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G21
http://www.w3.org/TR/WCAG20-TECHS/G133.html
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specific. It's

necessary

that

developers

consider this

provision and

ensure

conformance.

2.2.2 Pause,

Stop, Hide.

(Level A)

7.19 General Techniques:

http://www.w3.org/WAI/W

time-limits-pause

2.2.3 No

Timing. (Level

AAA)

7.19
 

2.2.4

Interruptions.

(Level AAA)

7.19
 

2.2.5 Re-

authenticating.

(Level AAA)

Not

applicable

 

2.3.1 Three

Flashes or

Below

Threshold.

(Level A)

7.1, paragraph

5

General Techniques:

http://www.w3.org/WAI/W

seizure-does-not-violate

2.3.2 Three

Flashes.(Level

AAA)

7.1, paragraph

5

 

2.4.1 Bypass

Blocks. (Level

A)

Not

applicable,

unless the

PDF includes

repetitive real

PDF9

General Techniques:

http://www.w3.org/WAI/W

navigation-mechanisms-

http://www.w3.org/WAI/WCAG20/quickref/#qr-time-limits-pause
http://www.w3.org/WAI/WCAG20/quickref/#qr-seizure-does-not-violate
http://www.w3.org/TR/WCAG20-TECHS/PDF9.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-skip
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content. Page

content, such

as running

headers and

footers, must

conform with

7.8.

2.4.2 Page

Titled. (Level

A)

7.1,

paragraphs 8

and 9

PDF18

2.4.3 Focus

Order. (Level

A)

7.1, paragraph

2, 7.18.1;

paragraph 2,

7.18.3

PDF3

2.4.4 Link

Purpose (In

Context).

(Level A)

7.18.5 PDF11

PDF13

2.4.5 Multiple

Ways. (Level

AA)

PDFs can

conform with

this provision

in several

ways,

including

outlines (7.17),

links (7.18.5),

and page

labels.

PDF2

General Techniques:

http://www.w3.org/WAI/W

navigation-mechanisms-

2.4.6 Headings

and Labels.

(Level AA)

7.4 General Techniques:

http://www.w3.org/WAI/W

navigation-mechanisms-

http://www.w3.org/TR/WCAG20-TECHS/PDF18.html
http://www.w3.org/TR/WCAG20-TECHS/PDF3.html
http://www.w3.org/TR/WCAG20-TECHS/PDF11.html
http://www.w3.org/TR/WCAG20-TECHS/PDF13.html
http://www.w3.org/TR/WCAG20-TECHS/PDF2.html
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-mult-loc
http://www.w3.org/WAI/WCAG20/quickref/#qr-navigation-mechanisms-descriptive
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2.4.7 Focus

Visible. (Level

AA)

Not

applicable

G149

G165 

G195

2.4.8 Location.

(Level AAA)
7.4, 7.17

 

2.4.9 Link

Purpose (Link

Only). (Level

AAA)

7.18.5
 

2.4.10 Section

Headings.

(Level AAA)

7.4
 

3.1.1 Language

of Page. (Level

A)

7.2, paragraph

3.

PDF16 

PDF19

3.1.2 Language

of Parts. (Level

AA)

7.2, paragraph

3.

PDF19

3.1.3 Unusual

Words. (Level

AAA)

Not

addressed in

ISO 14289.

See ISO

32000-1,

section 14.9.5.

 

3.1.4

Abbreviations.

(Level AAA)

Not

addressed in

ISO 14289.

See ISO

32000-1,

section 14.9.5.

 

http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G149
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G165
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G195
http://www.w3.org/TR/WCAG20-TECHS/PDF16.html
http://www.w3.org/TR/WCAG20-TECHS/PDF19.html
http://www.w3.org/TR/WCAG20-TECHS/PDF19.html
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3.1.5 Reading

Level. (Level

AAA)

No

Accessibility

Support

impact. This

rule is design-

specific. It's

necessary

that

application or

document

authors

consider this

provision and

ensure

conformance.

 

3.1.6

Pronunciation.

(Level AAA)

PDF provides

several

mechanisms

for deploying

media and

other options

for

pronunciation

assistance.

Design-

specific. It's

necessary

that authors

and

developers

consider this

provision and

ensure

conformance.

 

3.2.1 On Focus.

(Level A)
7.18,

paragraph 2

General Techniques:

http://www.w3.org/WAI/W

consistent-behavior-rece

http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-receive-focus
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3.2.2 On Input.

(Level A)
7.18,

paragraph 2

PDF15

3.2.3

Consistent

Navigation.

(Level AA)

7.1, paragraph

1, 7.17

PDF14

PDF17 

G61

3.2.4

Consistent

Identification.

(Level AA)

7.1, paragraph

1

General Techniques:

http://www.w3.org/WAI/W

consistent-behavior-cons

3.2.5 Change

on Request.

(Level AAA)

7.19,

paragraph 2

 

3.3.1 Error

Identification.

(Level A)

Design-

specific. It's

necessary

that authors

and

developers

consider this

provision and

ensure

conformance.

PDF5 

PDF22

3.3.2 Labels or

Instructions

(Level A)

 
PDF5 

PDF10

4.1.2 Name,

role, value

 
PDF10 

PDF12

http://www.w3.org/TR/WCAG20-TECHS/PDF15.html
http://www.w3.org/TR/WCAG20-TECHS/PDF14.html
http://www.w3.org/TR/WCAG20-TECHS/PDF17.html
http://www.w3.org/TR/2012/NOTE-WCAG20-TECHS-20120103/G61
http://www.w3.org/WAI/WCAG20/quickref/#qr-consistent-behavior-consistent-functionality
http://www.w3.org/TR/WCAG20-TECHS/PDF5.html
http://www.w3.org/TR/WCAG20-TECHS/PDF22.html
http://www.w3.org/TR/WCAG20-TECHS/PDF5.html
http://www.w3.org/TR/WCAG20-TECHS/PDF10.html
http://www.w3.org/TR/WCAG20-TECHS/PDF10.html
http://www.w3.org/TR/WCAG20-TECHS/PDF12.html
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